This domain name is up for sale. Please send your offer to hostmaster@elatomo.com.

Help with DTC P0481

Car Audio, Controllers, Wiring, Seats, Carpet, Interior painting, and more...

Moderators: daewoomofo, Moderators Group

Help with DTC P0481

Postby Kamitom73 » Sat Aug 18, 2012 4:58 pm

Hello Everyone,

I need help in clearing this fault code P0481. I have since change the fan control relay, ECM but I still cannot solve the Engine Check Light issue. The problem also lies with my number 2 fan being always "on" at high speed once my ignition is turned on.

Would anyone knows of such symptom and the solution to trouble shoot and rectify this?

Cheers.
Kamitom73
 
Posts: 5
Joined: Sat Aug 18, 2012 4:46 pm

Re: Help with DTC P0481

Postby turboetec » Sat Aug 18, 2012 11:18 pm

This may come in useful; jump to the section "P0481" --

http://gm-tis-lacetti.org.ua/en/documen ... 09.en.html
turboetec
 
Posts: 18
Joined: Tue Jun 19, 2012 7:00 pm

Re: Help with DTC P0481

Postby Kamitom73 » Tue Aug 21, 2012 3:27 pm

Thx a million, it helped heaps but the problem still exist. I have also replaced the cooling fan relay as well as a new ECM. But it seems the fault is in the wire harness. I am exhausted from diagnostic. Basically all the wire harness have never been tapered with. But recently I did change all sensors on the engine bay which I think might have been the cause of this issue.

I understand that the GM Tech II scan tool has a function of turning off or on the cooling fan relay. Can anyone verify or is certain that this is possible?

I am using Ultrguage EM1.0 as a scan too but once I try to clear the P0481 fault code, it only indicate a "off".....
Kamitom73
 
Posts: 5
Joined: Sat Aug 18, 2012 4:46 pm

Re: Help with DTC P0481

Postby turboetec » Tue Aug 21, 2012 3:51 pm

Firstly, I note that the manual says that the Malfunction Indicator Lamp (MIL, what you refer to as the Engine Check Light) will only go off after 3 consecutive validation cycles in which the diagnostic runs without a fault. I'm assuming that if you clear the Diagnostic Trouble Code (DTC) using your Ultraguage, the MIL should go off; if it still comes on that means the root problem has not yet been solved.

The manual diagnostic procedure detailed in the manual should allow you to isolate where the problem is coming from -- relay connections, ECM connection, relay control circuit, relay ignition feed circuit, relay, or the ECM. The procedure does look pretty tedious but I can't see a way around it if you want to isolate where the problem is coming from. Since you've replaced the relay and ECM, that's probably not where the problem is, but you still have the connections (or the wire harness itself, as you've pointed out), or the relay control / ignition feed circuits, that could be faulty.
turboetec
 
Posts: 18
Joined: Tue Jun 19, 2012 7:00 pm

Re: Help with DTC P0481

Postby Kamitom73 » Wed Aug 22, 2012 3:53 am

Is there any reference to check the ignition feed circuit?
Kamitom73
 
Posts: 5
Joined: Sat Aug 18, 2012 4:46 pm

Re: Help with DTC P0481

Postby turboetec » Thu Aug 23, 2012 8:01 am

Step 6, which follows immediately after Step 5:
(In Step 5, a test light is connected between relay coil terminals 86 and 85 in the relay harness connector.)

Step 6.
1. With the test light connected to ground, probe the ignition feed circuit in the relay harness connector.
2. Turn the ignition ON.
3. Does the test light illuminate?
If no, ==> Repair the faulty relay ignition feed circuit.
turboetec
 
Posts: 18
Joined: Tue Jun 19, 2012 7:00 pm

Re: Help with DTC P0481

Postby Kamitom73 » Fri Aug 24, 2012 2:06 pm

Thanks man, will give it a go this weekend.
Kamitom73
 
Posts: 5
Joined: Sat Aug 18, 2012 4:46 pm

Re: Help with DTC P0481

Postby Kamitom73 » Sun Sep 02, 2012 2:12 am

Problem found and solved.

Apparently after four days of checking and diagnosis, checks and trouble shooting, the problem was a bunch of harness wire under the engine compartment fuse box that melted together. Before this, through all checks, all signals in and out of individual sensor connector did not indicate any open circuit. The symptom of CEL and engine stall only happen when the car runs through water or driving in the rain, the car would misfire and stall, refusing to start. The harness was repaired and now the car runs great.

Thank you all for the help and advice. Greatly appreciate it.
Kamitom73
 
Posts: 5
Joined: Sat Aug 18, 2012 4:46 pm

Re: Help with DTC P0481

Postby turboetec » Sun Sep 02, 2012 9:51 am

No problem, Thomas! Glad you found and fixed the problem!

Guess that means your car is ready for tracking again! :smt023
turboetec
 
Posts: 18
Joined: Tue Jun 19, 2012 7:00 pm


Return to Electronics/Interior/Audio

Who is online

Users browsing this forum: No registered users and 1 guest